[SOLVED] EPSG 3003 not working?

Apr 23, 2012 at 8:09 PM

Hi everybody and thank you for this great tool.

In the faqs I've seen that EPSG 3003 is yet supported.

I'm using Geomedia 6.1 on windows Xp, "output to feature class" works fine when using EPSG 4326 features, when I try to export in postgis a feature in EPSG 3003 CRS the export fails and the GMOTTS.log is written:

"error inserting or updating teh especified cooridnate system"

I've downloaded also the source code but I'm not able to compile it (I've downloaded minGW but it seems I need MIDL, don't know what the hell is this).

Now when I'm tryng to load the EPSG3003.csf that is in the coordinate system folder, Geomedia says that the file is invalid.

Otherwise I can load EPSG3004.csf

What should I do?

Thanks

 

amedeo

 

 

Coordinator
Apr 24, 2012 at 7:13 PM

Hi Amedeo,

I have tested the following workflow:

- create access warehouse with EPSG 3003

- create a feature class and insert few records

- connect to PostGIS warehouse and go to OTFC, the EPSG 3003 was not in the target warehouse, so I have chosen "Maintain the source coordinate system"

- imported the data and everything went fine

Also I have no problem to open the EPSG3003.csf in GeoMedia.

Are you sure you have the latest GeoMedia hot fix installed? Also double check that you have the latest version of the PostGIS GDO installed, and your metadata conform to the latest design - e.g. the gfeatures is a view on gdo.gfeaturesbase table. You can try to drop the metadata and recreate them using the PostGIS GDO Database Utilities.

There used to be a problem similar to the one you describe, but I believe it has been already fixed.

Thanks, Pavel

Apr 26, 2012 at 6:39 AM

Hi Pavel thank you very much,

My about screen says "Geomedia Professional 6.1.0.2" I will ask my sysadmin (who keeps the intergraph suppport login) for new hotfixes.

I've downloaded postgis GDO 10.1.2 last week, created new postgis database with new metadata tables using db utilities provided in that version.

See you soon

amedeo

Jun 22, 2012 at 11:49 AM

Solved!

Updated Geomedia Professional with last hotfix and now opens the EPSG3003.csf

Also, I was using a wrong csf (made when using GM pro 5.2) for this coordinate sistem with datum undefined and projection "transverse mercator" the new one has projection "Gauss Bouaga - Italian zones"

Thank-you all !

amefad