Postgis - postgres supported versions

Jun 14, 2012 at 8:51 AM

I wonder if PostgisGDO supports postgis 1.5.latest and/or postgres 9.1.

I cannot find that info in readme files

Thanks

Jun 14, 2012 at 9:01 AM

I see libpq.dll included within BuildMS binaries is version 9.1.

Does it mean I cannot use BuildMS binaries to connect to a postgres 8.4 server ?

Is it enough to substitute that dll ?

Coordinator
Jun 14, 2012 at 9:34 AM

I am testing Postgres 8.3 + Postgis 1.5 and Postgres 9.1 + Postgis 2.0. Everything works. The libpq.dll version should not matter.

I just created a database with it_IT.UTF-8 collation and created a table using your script (in Postgis 2.0, the geometry definition does not work this way in Postgis 1.5 - at least not for me and according to Postgis documentation) and everything worked fine, except I found a small bug regarding writing 2D multipolygon geometries. If you contact me by e-mail, I would send you a patch for testing.

Thanks, Pavel